Go Back   Back Country Rebels - Forums > REBELS WITH A WRENCH > BRAND SPECIFIC TECH / DISCUSSION > POLARIS

Reply
 
Thread Tools Display Modes
  #1  
Old 02-28-2017, 08:16 PM
FlyZ28 FlyZ28 is offline
Member
 
Join Date: Nov 2009
Location: Covington, Wa
Posts: 46
FlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from AR
Unhappy Axys pulls hard up to 3/4 throttle

New 2016 Pro 800. Has about 350 miles on it now. But even since first ride, it pulls hard to 3/4 throttle, then the remaining 1/4 throttle it doesn't do anything more. Anyone experience this? Clutching? I recall a couple of pre 2008 Ski-doos I had did the same thing.

Thanks in advance for help.
Reply With Quote
  #2  
Old 02-28-2017, 09:16 PM
Mule's Avatar
Mule Mule is offline
"bcr forum security services"
 
Join Date: Nov 2009
Location: DM79LN
Posts: 29,275
Mule Offical PLPMule Offical PLPMule Offical PLPMule Offical PLP
Mule Offical PLPMule Offical PLPMule Offical PLPMule Offical PLPMule Offical PLPMule Offical PLPMule Offical PLPMule Offical PLP
Default

What are your RPMs at?
Stock clutching? (What spring/weights?)
Assuming you're past the 10-hour mark for the break-in fuse...
__________________
Crazy, not stupid | "Helmets make it hard to hear natural selection calling."
N* WebChat on irc://irc.nightstar.net/#snowmobiling
#155 | Mule's Photos | BackCountryRebels | ThumperTalk | Tekrider | TylersBA
I am a Snowmobiler!
Reply With Quote
  #3  
Old 03-01-2017, 08:23 PM
FlyZ28 FlyZ28 is offline
Member
 
Join Date: Nov 2009
Location: Covington, Wa
Posts: 46
FlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from AR
Default

RPM's are at 8100. I was riding at about 5,500' Yep, past the break-in period. The dealer set it up for our area which is 3,000' to 6,000'. I think they just put in per Polaris recommendation.

I'm just wondering if the situation is a result of improper clutching. Seems like it is to me, but I don't know for sure.
Reply With Quote
  #4  
Old 03-01-2017, 08:49 PM
Mule's Avatar
Mule Mule is offline
"bcr forum security services"
 
Join Date: Nov 2009
Location: DM79LN
Posts: 29,275
Mule Offical PLPMule Offical PLPMule Offical PLPMule Offical PLP
Mule Offical PLPMule Offical PLPMule Offical PLPMule Offical PLPMule Offical PLPMule Offical PLPMule Offical PLPMule Offical PLP
Default

What's it engaging at? And what weights?

Might need a little heavier rate primary spring... 8100's breddy gud, mine'll pull 8250 on a hard climb but 8000-8100 isn't bad. Start pushing that and it'll start to over-rev and all the unpleasantries that come with that.
__________________
Crazy, not stupid | "Helmets make it hard to hear natural selection calling."
N* WebChat on irc://irc.nightstar.net/#snowmobiling
#155 | Mule's Photos | BackCountryRebels | ThumperTalk | Tekrider | TylersBA
I am a Snowmobiler!
Reply With Quote
  #5  
Old 03-01-2017, 10:52 PM
john 624 john 624 is offline
Just Got Here
 
Join Date: Feb 2017
Location: Mi
Posts: 18
john 624 is an unknown quantity at this point
Default

Subscribing how to fix this. Heavier primary spring might help.
Reply With Quote
  #6  
Old 03-02-2017, 10:23 PM
FlyZ28 FlyZ28 is offline
Member
 
Join Date: Nov 2009
Location: Covington, Wa
Posts: 46
FlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from ARFlyZ28 Has earned a rub and tug from AR
Default

i want to say it engages at about 3,500. i'll check it again the next time i ride to make sure.

Thanks for the feedback
Reply With Quote
Reply
Back Country Rebels - Forums > REBELS WITH A WRENCH > BRAND SPECIFIC TECH / DISCUSSION > POLARIS

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:29 PM.

 

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Managed by wDa @ WD ™

Designed by Military Ltd