Go Back   Back Country Rebels - Forums > REBELS WITH A WRENCH > BRAND SPECIFIC TECH / DISCUSSION > SKI DOO

Reply
 
Thread Tools Display Modes
  #1  
Old 12-13-2009, 06:11 PM
Timber_Tramp's Avatar
Timber_Tramp Timber_Tramp is offline
BCR Resident Tramp
 
Join Date: Nov 2009
Location: Winfield BC
Posts: 2,678
Timber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLP
Timber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLP
Question Guess whats wrong......06 rev 800 wont hold Rpm....

....and was fouling mag side plug.

Whats your guess on the problem?

Ill do a compression check this week and get back to you.
Reply With Quote
  #2  
Old 12-13-2009, 06:25 PM
Backcountrypro Backcountrypro is offline
Just Got Here
 
Join Date: Dec 2009
Posts: 14
Backcountrypro Has earned a rub and tug from ARBackcountrypro Has earned a rub and tug from ARBackcountrypro Has earned a rub and tug from ARBackcountrypro Has earned a rub and tug from AR
Default

I am thinking it could be the rings. I am working on a 05 right now that had very little compression (105 psi/120 psi cold). We tore it down today the rings were flaked completely. We will install new piston and rings. I thought the 06 had the better rings though.
Reply With Quote
  #3  
Old 12-13-2009, 06:29 PM
Timber_Tramp's Avatar
Timber_Tramp Timber_Tramp is offline
BCR Resident Tramp
 
Join Date: Nov 2009
Location: Winfield BC
Posts: 2,678
Timber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLP
Timber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLP
Default

I did pistons and rings 2 seasons ago.

Im thinking its time again. Almost 4000 mi.
Reply With Quote
  #4  
Old 12-16-2009, 07:48 PM
Timber_Tramp's Avatar
Timber_Tramp Timber_Tramp is offline
BCR Resident Tramp
 
Join Date: Nov 2009
Location: Winfield BC
Posts: 2,678
Timber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLP
Timber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLPTimber_Tramp Offical PLP
Default

150 psi pto side
125 psi mag side

pulled the y pipe and you could see some scoring on the mag piston.

I hope the cylinder walls are ok....
Reply With Quote
  #5  
Old 12-16-2009, 09:39 PM
Backcountrypro Backcountrypro is offline
Just Got Here
 
Join Date: Dec 2009
Posts: 14
Backcountrypro Has earned a rub and tug from ARBackcountrypro Has earned a rub and tug from ARBackcountrypro Has earned a rub and tug from ARBackcountrypro Has earned a rub and tug from AR
Default

I have seen rings that were updated to the newer (suppose to be better) rings and they flaked also.
Reply With Quote
Reply
Back Country Rebels - Forums > REBELS WITH A WRENCH > BRAND SPECIFIC TECH / DISCUSSION > SKI DOO

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:08 AM.

 

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Managed by wDa @ WD ™

Designed by Military Ltd