Go Back   Back Country Rebels - Forums > REBELS WITH A WRENCH > BRAND SPECIFIC TECH / DISCUSSION > SKI DOO

Reply
 
Thread Tools Display Modes
  #11  
Old 01-15-2010, 01:43 PM
knightkrawler00's Avatar
knightkrawler00 knightkrawler00 is offline
REBEL
 
Join Date: Nov 2009
Location: NW Montana
Posts: 850
knightkrawler00 Has earned a reach around from Rebel
Default

Update and questions.

The noise has disappeared!

Is it possible that the engine was detonating at that RPM with no load? It knocked when the sled was hot and the RPM was hanging at 3200. It still had a 50/50 mix of last years fuel and fresh fuel. I'm thinking that a combination of being lean due to too small of pilot jets, old fuel and possibly timing was making the engine detonate. I say possibly timing because I don't know what the timing does at that engine speed. Since BRP put pilot jets that lean the engine out in order the meet emissions is it possible that they also have the timing advanced to meet emissions as well? The only thing that has changed, other than the clutch which did not change the noise, is the quality of the fuel. If it was engine detonation, why didn't the knock sensor do it's thing? Does the knock sensor work at that speed?
__________________
The Bill of Rights.

Brought to you by the Second Amendment.
Reply With Quote
Reply
Back Country Rebels - Forums > REBELS WITH A WRENCH > BRAND SPECIFIC TECH / DISCUSSION > SKI DOO

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:41 PM.

 

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Managed by wDa @ WD ™

Designed by Military Ltd