Go Back   Back Country Rebels - Forums > REBELS WITH A WRENCH > SLED HEADS

SLED HEADS General Sled Chat

Reply
 
Thread Tools Display Modes
  #1  
Old 10-24-2017, 10:51 AM
Snow_ME's Avatar
Snow_ME Snow_ME is offline
Prospect
 
Join Date: Nov 2011
Location: Westminster, CO
Posts: 181
Snow_ME Has earned a rub and tug from ARSnow_ME Has earned a rub and tug from ARSnow_ME Has earned a rub and tug from ARSnow_ME Has earned a rub and tug from ARSnow_ME Has earned a rub and tug from ARSnow_ME Has earned a rub and tug from ARSnow_ME Has earned a rub and tug from ARSnow_ME Has earned a rub and tug from ARSnow_ME Has earned a rub and tug from ARSnow_ME Has earned a rub and tug from ARSnow_ME Has earned a rub and tug from ARSnow_ME Has earned a rub and tug from AR
Default Motor Swap ?

I have an old 89 Mach that has a good 583 in it, but the suspension ad body and some other things are shot.
I picked up a 95 Mach parts sled that is only missing the 670 motor....hmm.

Am wondering if there will be any issues using the 670 CDI etc on the 583 or should I move those parts with the 583 as well?
Any thoughts or concerns I should watch for?

Everything on the 95 is in better shape just needs the power plant to make it go.
__________________
_____________________________________________
I'm a mechanical engineer, I've accepted that fact and learned to live with it. So you can deal with it too...
______________________________________________
89 SkiDoo Mach 1
96 SkiDoo Touring (wife)
Reply With Quote
Reply
Back Country Rebels - Forums > REBELS WITH A WRENCH > SLED HEADS

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:38 PM.

 

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Managed by wDa @ WD ™

Designed by Military Ltd